Laboratoire Microsoft |  CertifExpress 
 Le Forum de Réfèrence sur les Technologies Microsoft - http://www.forum-microsoft.org

[Resolu]Activer ajustement à l'heure d'été sur un réseau

Modérateurs : Modérateurs, Modérateurs_Systèmes

[Resolu]Activer ajustement à l'heure d'été sur un réseau

Message par nicolas.var » Mar 18 Juil 2006, 11:13

Bonjour tout le monde et d'avance merci pour votre futur éventuelle aide,

Voici mon problème :

Un grand nombre d'ordinateur sur notre réseau n'a pas la coche activer permettant de changer l'heure automatiquement au passe à l'heure d'été / hiver.

Ceci pose des problèmes avec des applications de gestion de temps.

Je dois donc activer cette option (coche été / hiver) pour que le fonctionnement de ces applications ne pose plus de problème.

Il est naturellement impossible de passer sur chaque ordinateur. Je me suis donc tourner vers la solution des "GPO" mais n'ai rien trouver de probant. Après quelques recherches, j'ai trouver les clefs de registre à modifier afin d'ajouter ou d'enlever cette coche. Donc, j'ai créer un script (modifiant le registre) qui sera ajouter au script de logon des users (pendant quelques jours). En testant ce script sur mon PC, j'ai remarquer que la fonction s'activait bien (coche mise) mais que après un certains temps, ou alors en redémarrant, la coche se désactivait d'elle même.

Me voici donc avec plusieurs questions :

-Avez-vous déjà été confronté à ce genre de problème et éventuellement avez-vous une autre solution que la modification du registre ?

-Peut-être que la coche se désactive à cose d'autre chose sur mon PC ?

-D'autres suggestions, idée, etc ?

Merci d'avoir atteind la fin de ce long message... et surtout merci à ceux qui se pencheront sur ce petit soucis ou qui connaitront la solution à ce problème.

A+
Dernière édition par nicolas.var le Lun 24 Juil 2006, 13:28, édité 1 fois.
nicolas.var
N00b
N00b
 
Message(s) : 5
Inscription : Mar 18 Juil 2006, 11:01

Message par SMike » Mar 18 Juil 2006, 11:56

Etrange par ce que normalement dans un domaine Active Directory par défaut tous les PC se synchronisent avec le DC qui possède le rôle "PDC Emulator". As tu fais des modifications particulière dans ton schéma ou de ta tratégie de domaine par défaut?

PS: Je déplace vers Active Directory.
Michael Schamberger
Hewlett-Packard France
Avatar de l’utilisateur
SMike
Keyboard Master
Keyboard Master
 
Message(s) : 5501
Inscription : Mer 09 Oct 2002, 17:34
Localisation : Mulhouse

Message par oussema » Mar 18 Juil 2006, 11:59

Bonjour,

Pour synchroniser l'heure du client avec un serveur de temps
Tapez w32tm /resync a l'invite de commande

Cette procédure ne fonctionne que sur les ordinateurs appartenant à un domaine

@+
Avatar de l’utilisateur
oussema
Grand Master Flash
Grand Master Flash
 
Message(s) : 2598
Inscription : Mar 27 Juin 2006, 15:51
Localisation : Tunis Tunisie

Message par nicolas.var » Mar 18 Juil 2006, 12:48

SMike a écrit :Etrange par ce que normalement dans un domaine Active Directory par défaut tous les PC se synchronisent avec le DC qui possède le rôle "PDC Emulator". As tu fais des modifications particulière dans ton schéma ou de ta tratégie de domaine par défaut?

PS: Je déplace vers Active Directory.


En réalité, les ordinateurs ont été installé volontairement de cette manière (coche enlever) et ceci pour des raisons que je ne connais pas. Ensuite cette manière de faire à été inscrite dans la doc d'installation ! Tout ceci à été fait par mon prédécesseur !

J'ai fait des tests et je sais que cette coche peut être activer sans problème sur le système en place, il faut juste que je trouve la façon de l'automatiser.

Merci pour ton aide !

A plus
nicolas.var
N00b
N00b
 
Message(s) : 5
Inscription : Mar 18 Juil 2006, 11:01

Message par bigstyle » Mar 18 Juil 2006, 12:55

C'est la valeur DisableAutoDaylightTimeSet à supprimer dans HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation
Freddy ELMALEH - Consultant Freelance - Active IT (spécialisé dans la Sécurité (Audit système, audit de sites Web, Tests d'intrusion), Infra Microsoft (Active Directory,etc.)) - Image Image Image
MVP Windows Server - Directory Services (2007 à 2013)
MCITP Enterprise Administrator (2008) - MCSE 2000/2003 Security - MCSA Messaging 2000/2003
Bibliographie : "Windows Server 2012 - Administration avancée". --
"Windows 8 et Office 2013 - Déploiement des postes de travail en entreprise" -- "La sécurité sous Windows 7". -- "Windows Server 2008 R2 - Administration avancée". -- " et d'autres ...".
Tout ce que je sais,c'est que je ne sais rien.
Image
Avatar de l’utilisateur
bigstyle
Forum Master
Forum Master
 
Message(s) : 19223
Inscription : Ven 01 Fév 2002, 22:46
Localisation : Paris

Re: Activer ajustement à l'heure d'été sur un réseau

Message par nicolas.var » Mar 18 Juil 2006, 15:15

nicolas.var a écrit :Après quelques recherches, j'ai trouver les clefs de registre à modifier afin d'ajouter ou d'enlever cette coche. Donc, j'ai créer un script (modifiant le registre) qui sera ajouter au script de logon des users (pendant quelques jours). En testant ce script sur mon PC, j'ai remarquer que la fonction s'activait bien (coche mise) mais que après un certains temps, ou alors en redémarrant, la coche se désactivait d'elle même.


Merci pour ta réponse mais j'avais déjà trouver cette valeure. Le problème c'est que ça se décoche après quelque temps !

Merci quand même !
nicolas.var
N00b
N00b
 
Message(s) : 5
Inscription : Mar 18 Juil 2006, 11:01

Message par bigstyle » Mar 18 Juil 2006, 15:17

Si ca se decoche c est peut etre que cette derniere est définie au niveau d'une GPO.

Fais un rsop.msc ou gpresult (suivant que ton poste client se trouve sous XP ou 2000) et regardes si tu n'as pas une GPO qui modifie ce paramètre.
Freddy ELMALEH - Consultant Freelance - Active IT (spécialisé dans la Sécurité (Audit système, audit de sites Web, Tests d'intrusion), Infra Microsoft (Active Directory,etc.)) - Image Image Image
MVP Windows Server - Directory Services (2007 à 2013)
MCITP Enterprise Administrator (2008) - MCSE 2000/2003 Security - MCSA Messaging 2000/2003
Bibliographie : "Windows Server 2012 - Administration avancée". --
"Windows 8 et Office 2013 - Déploiement des postes de travail en entreprise" -- "La sécurité sous Windows 7". -- "Windows Server 2008 R2 - Administration avancée". -- " et d'autres ...".
Tout ce que je sais,c'est que je ne sais rien.
Image
Avatar de l’utilisateur
bigstyle
Forum Master
Forum Master
 
Message(s) : 19223
Inscription : Ven 01 Fév 2002, 22:46
Localisation : Paris

Message par nicolas.var » Mer 19 Juil 2006, 7:44

après contrôle, pas de GPO local ni au niveau du domaine !

Merci pour votre aide, je vais chercher dans une autre direction ! Mais si tout d'un coup vous avez une autre idée, elle sera toujours bonne à prendre !

Bonne journée a tous
nicolas.var
N00b
N00b
 
Message(s) : 5
Inscription : Mar 18 Juil 2006, 11:01

Message par bigstyle » Mer 19 Juil 2006, 9:04

Il faudrait essayer de trouver aprés quel intervalle de temps la valeur réapparait car à part une GPO qui soit rejouée ou un script au login, je ne vois pas comment une telle modification peut etre effectuée automatiquement (et surtout dans quel but)
Freddy ELMALEH - Consultant Freelance - Active IT (spécialisé dans la Sécurité (Audit système, audit de sites Web, Tests d'intrusion), Infra Microsoft (Active Directory,etc.)) - Image Image Image
MVP Windows Server - Directory Services (2007 à 2013)
MCITP Enterprise Administrator (2008) - MCSE 2000/2003 Security - MCSA Messaging 2000/2003
Bibliographie : "Windows Server 2012 - Administration avancée". --
"Windows 8 et Office 2013 - Déploiement des postes de travail en entreprise" -- "La sécurité sous Windows 7". -- "Windows Server 2008 R2 - Administration avancée". -- " et d'autres ...".
Tout ce que je sais,c'est que je ne sais rien.
Image
Avatar de l’utilisateur
bigstyle
Forum Master
Forum Master
 
Message(s) : 19223
Inscription : Ven 01 Fév 2002, 22:46
Localisation : Paris

Message par nicolas.var » Jeu 20 Juil 2006, 13:52

Pour information mon problème est résolu. En effet, j'ai testé le même procéder (modification des clefs de registre) sur un autre PC et tout à bien fonctionné.

Donc j'ai fait une recherche sur mon PC et j'avais un fichier ADM manquant que j'avais utilisé pour ce genre d'opération. Malgré que ce fichier n'existait plus, il continuait d'agir. Je l'ai donc recréé et ensuite je l'ai supprimer proprement via la console gpo.

Cette fois tout semble ok !

Je vous remerci tous pour votre aide précieuse.

Bonne journée

A plus
nicolas.var
N00b
N00b
 
Message(s) : 5
Inscription : Mar 18 Juil 2006, 11:01

Message par bigstyle » Jeu 20 Juil 2006, 13:54

nicolas.var a écrit :Pour information mon problème est résolu. En effet, j'ai testé le même procéder (modification des clefs de registre) sur un autre PC et tout à bien fonctionné.

Donc j'ai fait une recherche sur mon PC et j'avais un fichier ADM manquant que j'avais utilisé pour ce genre d'opération. Malgré que ce fichier n'existait plus, il continuait d'agir. Je l'ai donc recréé et ensuite je l'ai supprimer proprement via la console gpo.

Cette fois tout semble ok !

Je vous remerci tous pour votre aide précieuse.

Bonne journée

A plus


Bon ben cool que ca fonctionne ! :D

Et pour la GPO, ce type de probleme apparait si tu supprimes une GPO directement sans la désactiver.
Tu as eu le bon reflexe de recréer la GPO !
Freddy ELMALEH - Consultant Freelance - Active IT (spécialisé dans la Sécurité (Audit système, audit de sites Web, Tests d'intrusion), Infra Microsoft (Active Directory,etc.)) - Image Image Image
MVP Windows Server - Directory Services (2007 à 2013)
MCITP Enterprise Administrator (2008) - MCSE 2000/2003 Security - MCSA Messaging 2000/2003
Bibliographie : "Windows Server 2012 - Administration avancée". --
"Windows 8 et Office 2013 - Déploiement des postes de travail en entreprise" -- "La sécurité sous Windows 7". -- "Windows Server 2008 R2 - Administration avancée". -- " et d'autres ...".
Tout ce que je sais,c'est que je ne sais rien.
Image
Avatar de l’utilisateur
bigstyle
Forum Master
Forum Master
 
Message(s) : 19223
Inscription : Ven 01 Fév 2002, 22:46
Localisation : Paris


Retour vers Autres Problèmes AD

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 7 invité(s)



Accueil | News | Articles | Tips | Outils | Certification | Easters Eggs
Essentiels | Glossaire | Vidos | Whitepapers | Essentiels | Bote Scripts
Conditions d'utilisation & Copyright | Respect de la vie prive