Laboratoire Microsoft |  CertifExpress 
 Le Forum de Réfèrence sur les Technologies Microsoft - http://www.forum-microsoft.org

[RDS] Accès SSO portail Web

Postez ici toutes vos questions à propos du service de Terminaux de Windows (TSE/Remote Desktop)

Modérateurs : Modérateurs, Modérateurs_Systèmes

[RDS] Accès SSO portail Web

Message par ragkiki » Lun 14 Mars 2011, 19:54

Bonjour,

j'ai mis en place le portail TS Web Access sur un 2008 R2
Mes clients sont tous en Seven

j'ai publié une application visible depuis le portail Web et ca marche
j'ai mis en place un certificat coté serveur.

lorsque j'arrive sur mon portail web, je me logue avec mes id et j'arrive sur la page où se trouve les applis publiées. Si je lance une appli le SSO fonctionne bien, j'ai pas besoin de me reloguer.

Ma question est la suivante : est-il possible d'afficher directement la page des applications sans à avoir à se loguer sur le portail Web ? L'idée étant que le portail Web utilise les login Windows ? (tous les users sont dans un domaine windows 2008)

Merci de votre aide.
ragkiki
Full Member
Full Member
 
Message(s) : 104
Inscription : Mer 29 Mars 2006, 16:37

Re: [RDS] Accès SSO portail Web

Message par eperromat » Jeu 17 Mars 2011, 19:30

Le soucis ne doit pas venir de RDS, mais d'IIS je pense
Eric Perromat
[MVP Windows Server - Terminal Server]
Visitez Mon nouveau site Web, et participez à mon forum TSE/Citrix
eperromat
Grand Master Flash
Grand Master Flash
 
Message(s) : 2836
Inscription : Dim 02 Mai 2004, 14:40
Localisation : Gironde

Re: [RDS] Accès SSO portail Web

Message par ragkiki » Ven 18 Mars 2011, 10:08

merci pour votre réponse,

vous me dites donc que c'est possible d'utiliser du SSO pour accéder au portail TS WEB ....
je vais voir du côté d'IIS....
vous savez quel paramètre doit être modifié par hasard ^^ ?
ragkiki
Full Member
Full Member
 
Message(s) : 104
Inscription : Mer 29 Mars 2006, 16:37

Re: [RDS] Accès SSO portail Web

Message par calamarz » Ven 18 Mars 2011, 13:10

J'ai le même probleme et je bosse dessus aujourd'hui je viens de trouver ceci http://support.microsoft.com/kb/258063 a priori:
- Le site doit etre dans la zone intranet
- l'authentifcation sur le IE doit etre en zone intranet

Je n'arrive pas non plus a me connecter automatiquement, je test les droits sous IIS via "l'authentification windows" pour le moment idem.

Je continu !!!
calamarz
Junior
Junior
 
Message(s) : 41
Inscription : Jeu 17 Mars 2011, 16:48

Re: [RDS] Accès SSO portail Web

Message par ragkiki » Ven 18 Mars 2011, 14:17

ok merci pour les infos....je continu également mes recherches...
et je reposte si je trouve bien sur :p
ragkiki
Full Member
Full Member
 
Message(s) : 104
Inscription : Mer 29 Mars 2006, 16:37

Re: [RDS] Accès SSO portail Web

Message par calamarz » Ven 18 Mars 2011, 14:29

Oui nous ne devons pas etre les seuls a vouloir faire ce type de conf :-)

Voila j'arrive maintenant a supprimer la premiere authentification mais maintenant je dois a nouveau saisir le mot login/password pour l'execution d'une application :-(

Voici la manipulation:

Edit the C:\Windows\Web\RDWeb\Pages\web.config file:
- un-comment <authentication mode=”Windows”/> section
- comment out the <authentication mode=”Forms”> section.
- comment out the <modules> and <security> sections in the <system.webServer> section at the end of the file.
calamarz
Junior
Junior
 
Message(s) : 41
Inscription : Jeu 17 Mars 2011, 16:48

Re: [RDS] Accès SSO portail Web

Message par ragkiki » Ven 18 Mars 2011, 15:53

j'ai fait comme toi et j'ai également une fenetre de login pour lancer les applis
l'accès au web acces fonctionne sans demande de login

pour info, avant de modifier le wen.config, le lancement des applis fonctionnait sans demande de login....

une idée ?
ragkiki
Full Member
Full Member
 
Message(s) : 104
Inscription : Mer 29 Mars 2006, 16:37

Re: [RDS] Accès SSO portail Web

Message par calamarz » Ven 18 Mars 2011, 16:02

Au final deux possibilités pour le moment:
1- Pas de modification du web.config et donc login sur le portail rdweb avant acces aux applications qui peuvent se lancer sans login
2- Modification du web.config et plus de login sur le portail pour l'acces aux applications publiées mais login pour l'execution des applications

Grrrrr :-) enfin je continu aussi !!!
calamarz
Junior
Junior
 
Message(s) : 41
Inscription : Jeu 17 Mars 2011, 16:48

Re: [RDS] Accès SSO portail Web

Message par ragkiki » Ven 18 Mars 2011, 16:45

bon on a le meme probleme :))
je continu aussi...
ragkiki
Full Member
Full Member
 
Message(s) : 104
Inscription : Mer 29 Mars 2006, 16:37

Re: [RDS] Accès SSO portail Web

Message par ragkiki » Lun 21 Mars 2011, 11:45

bonjour,

alors des news sur ce problème ?
ragkiki
Full Member
Full Member
 
Message(s) : 104
Inscription : Mer 29 Mars 2006, 16:37

Re: [RDS] Accès SSO portail Web

Message par calamarz » Lun 21 Mars 2011, 12:09

Je reprends mes tests, mais je me demande serieusement si il est possible de chinter les deux authentifications (IE et applications deportées).
calamarz
Junior
Junior
 
Message(s) : 41
Inscription : Jeu 17 Mars 2011, 16:48

Re: [RDS] Accès SSO portail Web

Message par ragkiki » Lun 21 Mars 2011, 12:38

je ne sais pas, je vais voir avec le support technique microsoft
ragkiki
Full Member
Full Member
 
Message(s) : 104
Inscription : Mer 29 Mars 2006, 16:37

Re: [RDS] Accès SSO portail Web

Message par calamarz » Lun 21 Mars 2011, 14:15

Ahh je crois avoir trouvé le truc tres tres cxx bref il faut bien faire la modification dans le web.config pour l'activation de l'authentification windows mais en plus il faut cocher une fois sur le portail l'option en bas pour l'ordinateur prive et la il est possible de se connecter sans authentification reste a voir comment activer cette option de manière automatique.
calamarz
Junior
Junior
 
Message(s) : 41
Inscription : Jeu 17 Mars 2011, 16:48

Re: [RDS] Accès SSO portail Web

Message par calamarz » Lun 21 Mars 2011, 14:34

Ok la modification pour être toujours en ordinateur privé se trouve dans le fichier "default.aspx" dans RDWEB --> PAGES --> fr-FR, modifier la valeur a true pour:
"bPrivateMode = false" dans le zone "Page Variables"
calamarz
Junior
Junior
 
Message(s) : 41
Inscription : Jeu 17 Mars 2011, 16:48

Re: [RDS] Accès SSO portail Web

Message par ragkiki » Lun 21 Mars 2011, 15:21

meme apres avoir fait ces modifs, on me demande de me reconnecter lorsque je lance une appli......la case "ordinateur privé" est bien cochée par défaut...
si je rentre le password et que je relance une appli ca va marcher mais apres reboot ca marche plus...
ragkiki
Full Member
Full Member
 
Message(s) : 104
Inscription : Mer 29 Mars 2006, 16:37

Suivant

Retour vers Terminal Services

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Yahoo [Bot] et 5 invité(s)



Accueil | News | Articles | Tips | Outils | Certification | Easters Eggs
Essentiels | Glossaire | Vidos | Whitepapers | Essentiels | Bote Scripts
Conditions d'utilisation & Copyright | Respect de la vie prive